Undefined method mime_type in Mailer Preview when using Attachments working with Actionmailer


+3 votes
asked Feb 17, 2016 by select_2817 (1,290 points)
I've created mailer in my Rails 4 application, which works perfectly well when there are no attachments to emails.

4 Answers

0 votes
answered May 6, 2016 by Create5676 (480 points)
selected May 8, 2016 by guvfor
 
Best answer
Summary what I have found from this thread and other solutions. Also accept a specific path as parameter
0 votes
answered Feb 20, 2016 by Gurlouth (3,900 points)
Same like the Preview for mail with attachments Issue #135 fphilipe ... and other android play store doing
For details look here
0 votes
answered Mar 22, 2016 by lam_9093 (190 points)
I have struggled with this as well and I believe I understand the problem now
Here is a working example http://www.horde.org/apps/groupware/docs/CHANGES
commented Mar 22, 2016 by Hfr_4283_gri (380 points)
One problem with this trick is that description attribute cannot be localized. This resolved the problem for me
0 votes
answered May 3, 2016 by Marroguinwel (160 points)
I have finally figured out what causes this issue
I think the article at PHP - Help Sending Html Email With Phpmailer ... will answer your questions

What is Geekub?

Q&A site for professional and enthusiast programmers, software developers and other technical users. With your help, we hope to work together to build a library of detailed answers to just about any question that is related to programming!







...